読者です 読者をやめる 読者になる 読者になる

めもぶろぐ

お勉強したこと、趣味なんかを適当に書いてます。。。

cisco 一部スイッチ設定 メモ

なんかこのようなものが残っていたので、こちらに転載する。
なんか微妙なメモだが。



=============================================================
インターフェースの初期化
=============================================================
default interface fa0/0

=============================================================
コンフィグモードで、設定を確認する
=============================================================
do show run

=============================================================
VTPの解除
=============================================================
vtp mode transparent


=============================================================
vlan作成
=============================================================
※インターvlanルーティングの場合は、vlanを作成し、
vlanにipを振ればルーティングされる
=============================================================
int fa0/0
vlan 100
name vlan100
exit

int fa0/0
switchport mode access
switchport access vlan 100

int vlan 100
ip address xxx.xxx.xxx.xxx 255.255.255.0

=============================================================
IPアドレスを消去
=============================================================
int vlan 100
no ip address


=============================================================
vlanの確認
=============================================================
show vlan
show vlan-switch


=============================================================
スタティックルートの設定
=============================================================
ip route 10.10.10.10 255.255.255.0 vlan 100
ip route 宛先 マスク ネクストホップ



=============================================================
ルートの確認
=============================================================
show ip route


=============================================================
インターフェースの確認
=============================================================
show ip int brief

=============================================================
トランクポートの設定
=============================================================
int fa0/0
switchport mode trunk
switchport trunk encapsulation dot1q
show int fa0/0 switchport


=============================================================
トランクポートの設定 allowd vlan
※vlan作成済み trunk設定済み
=============================================================
switchport trunk allowed add vlan 200



*****************************************************
ciscoスイッチ 設定例 -インターVLNAルーティングの設定-
*****************************************************
+-------+-------+-------+-------+-------+-------+-------+-------+
+ fa0/0 + fa0/1 + fa0/2 + fa0/3 + fa0/4 + fa0/5 + fa0/6 + fa0/7 +
+-------+-------+-------+-------+-------+-------+-------+-------+
+ vlan10+       + vlan20+       +       +       +       + trunk +
+-------+-------+-------+-------+-------+-------+-------+-------+

default interface fa0/0
default interface fa0/2
default interface fa0/7

(config)#vlan 10
(config-vlan)#name vlan10
(config-vlan)#exit
(config)#vlan 20
(config-vlan)#name vlan20
(config-vlan)#exit
(config)#int fa0/0
(config-if)#switchport mode access
(config-if)#switchport access vlan10
(config-if)#exit
(config)#
(config)#int fa0/2
(config-if)#switchport mode access
(config-if)#switchport access vlan20
(config-if)#exit
(config)#int fa0/7
(config-if)#switchport mode trunk
(config-if)#switchport trunk capsulation dot1q
(config-if)#switchport trunk allowed add vlan10
(config-if)#switchport trunk allowed add vlan20
(config-if)#exit
(config)#
(config)#int vlan10
(config-if)#ip address 10.10.10.10 255.255.255.0
(config-if)#exit
(config)#
(config)#int vlan20
(config-if)#ip address 100.100.100.100 255.255.255.0
(config-if)#exit
(config)#




ちなみに、スイッチとサーバ間もしくはスイッチと作業端末間においては
ポートのリンクアップ時間を短縮するためportfast設定を入れたりする。

スイッチ間ではやらない。

spanning-tree portfast 

こんなコマンドをインターフェースに対して指定してあげれば良いだけ。
設定しないとリンクアップするまで結構時間がかかる。
初期化して、バカハブ状態にするだけだと不十分なところがあるので、
このような設定をしてみるのもいいと思う。


また、複数ポートで同一のトランクポート設定を入れれば、チャネルも組んで設定することができる。帯域を増やせたりするので便利だが、対向のスイッチも同様の設定を入れるようにすること。


以上。

広告を非表示にする